Installation is not successful.

Posts: 2
Joined: Thu Sep 14, 2023 9:34 pm
 Fri Sep 15, 2023 4:45 am • via Web
I've tried to enable/delete data various times at this point, and the extension will not install no matter what I've tried.

When I try to enable the extension, I get the following error:

Code: Select all
General Error
SQL ERROR [ mysqli ]

Table 'u620182484_ared2020.phpbb_reactions' doesn't exist [1146]


INSERT INTO phpbb_reactions (reaction_title, reaction_color, reaction_image, reaction_order, reaction_score, reaction_enabled) VALUES ('REACTION_LIKE', '#0472f9', './reaction/like.svg', 1, 1, 1), ('REACTION_LOVE', '#fb003d', './reaction/love.svg', 2, 1, 1), ('REACTION_MATTER', '#fb003d', './reaction/matter.svg', 3, 1, 1), ('REACTION_ENJOY', '#fcad04', './reaction/enjoy.svg', 4, 0, 1), ('REACTION_SURPRISE', '#fcad04', './reaction/surprise.svg', 5, 0, 1), ('REACTION_SAD', '#006b9c', './reaction/sad.svg', 6, 0, 1), ('REACTION_ANGRY', '#fc0e00', './reaction/angry.svg', 7, -1, 1)


FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 1023
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 202
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 682
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 393
CALL: phpbb\db\driver\driver->sql_multi_insert()

FILE: [ROOT]/ext/canidev/reactions/migrations/v100.php
LINE: 192
CALL: phpbb\db\driver\factory->sql_multi_insert()

FILE: (not given by php)
LINE: (not given by php)
CALL: canidev\reactions\migrations\v100->add_basic_reactions()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 715
CALL: call_user_func_array()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 662
CALL: phpbb\db\migrator->run_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 437
CALL: phpbb\db\migrator->process_data_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 288
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 241
CALL: phpbb\db\migrator->update_do()

FILE: [ROOT]/phpbb/extension/base.php
LINE: 78
CALL: phpbb\db\migrator->update()

FILE: [ROOT]/ext/canidev/reactions/ext.php
LINE: 69
CALL: phpbb\extension\base->enable_step()

FILE: [ROOT]/phpbb/extension/manager.php
LINE: 231
CALL: canidev\reactions\ext->enable_step()

FILE: [ROOT]/includes/acp/acp_extensions.php
LINE: 209
CALL: phpbb\extension\manager->enable_step()

FILE: [ROOT]/includes/functions_module.php
LINE: 676
CALL: acp_extensions->main()

FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()

If I try to delete the data, it merely goes to a blank page. I've tried downgrading to 1.0.0, but it didn't do anything. I've gotten various errors, but this is the latest one and after my board went down due to some missing table error, I would rather not risk it further.

For context, I used to have the Reactions extension by Steve that was previously mentioned by another user in a post here. I had a similar experience as them, but unfortunately, I can't seem to solve the problem. There's no remains of the previous extension either in the tables or anywhere I could locate through phpmyadmin, and I can't find anything left through the Systems module on the ACP.

Any help would be appreciated. I don't know what else to do. At this point, I'll settle for the option to somehow be able to delete the data and erase the extension from the list, because I fear it's going to be stuck there for a while.

Thanks in advance.

Posts: 2
Joined: Thu Sep 14, 2023 9:34 pm
 Sat Sep 16, 2023 7:33 pm • via Web
I tried copying the tables from my test board (where the extension works as expected) to the main one, and that at least seemed to do the trick to get rid of the previous error message, but I still can't enable the extension as I'm now getting this message:

Code: Select all
Something went wrong during the request and an exception was thrown. The changes made before the error occurred were reversed to the best of our abilities, but you should check the board for errors.
The config setting "reactions_version" unexpectedly does not exist.

I'm assuming I'm missing something in terms of transferring from the test board or making it anew in the live board, but I've reached the end of what I can do.

Any help would be greatly appreciated.
User avatar
Site Admin
Posts: 1975
Joined: Fri Jun 17, 2011 12:15 am
Location: España (Spain)
 Wed Sep 20, 2023 2:20 pm • via Web

Based on the first error, for some reason the extension installer doesn't seem to be creating the phpbb_reactions table.

Have you checked to see if any errors appear in the server error log when installing the extension?

Who is online

Users browsing this forum: No registered users and 1 guest