Problem during update



Avdon
 
Posts: 5
Joined: Mon Jun 17, 2019 12:15 am
 Mon Jan 04, 2021 8:59 am • via Web
Hello,
while I was trying to update the extension I ran into problems. I have tried to solve these but made things worst.
Now I am in Situation where I can't login to the administration panel at all, which also means I can't deactivate the extension!
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/class_loader.php on line 160: require(./../ext/canidev/blockgets/libraries/json_response.php): failed to open stream: No such file or directory

Fatal error: require(): Failed opening required './../ext/canidev/blockgets/libraries/json_response.php' (include_path='.:/usr/lib/php7.4') in /homepages/22/d762309989/htdocs/clickandbuilds/phpBB/MyZusammenarbeit/phpbb/class_loader.php on line 160

So my only choice is to uuninstall the extension manually, which I don't know how to do!

I am in desperate need for help here!

Best Regards, Danny
User avatar
IvanPF
Site Admin
 
Posts: 1865
Joined: Fri Jun 17, 2011 12:15 am
Location: España (Spain)
 Tue Jan 05, 2021 11:51 am • via Web
Hi,

From the error you mention, it seems that you have not correctly uploaded all the files of the extension since version 2.0.1 does not use the file "/ext/canidev/blockgets/libraries/json_response.php".
It is a file from version 2.0.0

It is possible that some file has not been uploaded correctly

Avdon
 
Posts: 5
Joined: Mon Jun 17, 2019 12:15 am
 Tue Jan 05, 2021 1:20 pm • via Web
Hallo,
I have one more time made sure that the files from version 2.0.1 are all uploaded:
But I still get the same error message:
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/class_loader.php on line 160: require(./../ext/canidev/blockgets/libraries/json_response.php): failed to open stream: No such file or directory

Fatal error: require(): Failed opening required './../ext/canidev/blockgets/libraries/json_response.php' (include_path='.:/usr/lib/php7.4') in /homepages/22/d762309989/htdocs/clickandbuilds/phpBB/MyZusammenarbeit/phpbb/class_loader.php on line 160
User avatar
IvanPF
Site Admin
 
Posts: 1865
Joined: Fri Jun 17, 2011 12:15 am
Location: España (Spain)
 Tue Jan 05, 2021 2:01 pm • via Web
I have reviewed all the code of 2.0.1 and nowhere loads that file.
Also, no one has reported a similar bug since that version came out.

The error that appears does not reflect its origin, so it is difficult to help you without being able to see it directly.
Is there a possibility that you can give me temporary FTP access to your forum to review it?

Avdon
 
Posts: 5
Joined: Mon Jun 17, 2019 12:15 am
 Thu Jan 07, 2021 10:02 am • via Web
Hello,
I have sent you all necessary info for the access per E-Mail.
User avatar
IvanPF
Site Admin
 
Posts: 1865
Joined: Fri Jun 17, 2011 12:15 am
Location: España (Spain)
 Thu Jan 07, 2021 1:28 pm • via Web
I have seen the email but I do not need access to the forum, I need access to FTP, to see the files and look for the cause of the problem.

Avdon
 
Posts: 5
Joined: Mon Jun 17, 2019 12:15 am
 Thu Jan 07, 2021 2:17 pm • via Web
I have sent both of them in 2 seperate Emails
User avatar
IvanPF
Site Admin
 
Posts: 1865
Joined: Fri Jun 17, 2011 12:15 am
Location: España (Spain)
 Fri Jan 08, 2021 2:29 pm • via Web
Sorry, I had not seen the other email

I have fixed your ACP access problem, it was simply a forum cache problem. For some reason it had not been purged and it kept loading obsolete files.
On the other hand, I have corrected other problems you have by hand, because when correcting that error, others appeared, all derived from the fact that you are using phpBB 3.2.8 with php 7.4 (they are not compatible). You should update phpBB or change the version of php to 7.2 so that you don't get other errors.

Avdon
 
Posts: 5
Joined: Mon Jun 17, 2019 12:15 am
 Fri Jan 08, 2021 5:35 pm • via Web
Thank you very much! I really appreciate it!

Best Regards, Danny

Who is online

Users browsing this forum: No registered users and 1 guest