Update problem




atarikiki
 
Posts: 3
Joined: Wed May 22, 2019 7:58 am

Update problem

Postby atarikiki » Wed May 22, 2019 8:54 am • via Web
Hello.

I want to update cBB Chat from 1.1.3 to 1.2.0.

phpBB 3.2.3
MySQL 10.2.24-MariaDB
PHP 7.1.28

I followed instructions but as soon as I upload 1.2.0 I lose ACP (and the whole forum) acces, showing this error :

Code: Select all
Fatal error: Uncaught TypeError: Argument 1 passed to canidevchateventlistener::__construct() must be an instance of canidevchatlibrarieschat, instance of phpbbconfigdb given, called in /home/forum/public_html/cache/production/container_dbdbe80dc7030ae9bd39ee30cca82130.php on line 1141 and defined in /home/forum/public_html/ext/canidev/chat/event/listener.php:36 Stack trace: #0 /home/forum/public_html/cache/production/container_dbdbe80dc7030ae9bd39ee30cca82130.php(1141): canidevchateventlistener->__construct(Object(phpbbconfigdb), Object(phpbb_cache_container), Object(phpbbcontrollerhelper), Object(phpbbrequestrequest), Object(phpbbtemplatetwigtwig), Object(phpbbuser)) #1 /home/forum/public_html/vendor/symfony/dependency-injection/Container.php(297): phpbb_cache_container->getCanidev_Chat_ListenerService() #2 /home/forum/public_html/vendor/symfony/dependency-injection/ContainerBuilder.php(446): SymfonyComponentDependencyInjectionContainer->get('canidev.chat.li...', 2) #3 /home/forum in /home/forum/public_html/ext/canidev/chat/event/listener.php on line 36


Thanks for your help.
User avatar

IvanPF
Site Admin
 
Posts: 1641
Joined: Fri Jun 17, 2011 12:15 am
Location: España (Spain)

Re: Update problem

Postby IvanPF » Wed May 22, 2019 9:15 am • via Web
Hi,

Have you deactivated the extension before uploading the new files?


atarikiki
 
Posts: 3
Joined: Wed May 22, 2019 7:58 am

Re: Update problem

Postby atarikiki » Wed May 22, 2019 9:31 am • via Web
Yes I did.
I didn't mess with the language pack (it's a french forum).
The forum was installed by another guy who left.


atarikiki
 
Posts: 3
Joined: Wed May 22, 2019 7:58 am

Re: Update problem

Postby atarikiki » Wed May 22, 2019 8:49 pm • via Web
My bad...

I used "Chat page enabled = yes" to disable the chat.
Using the acp_extensions solved my problem.

Who is online

Users browsing this forum: No registered users and 1 guest

cron