cBB Editor error, breaks the ACP




Swamp_Monkey
 
Posts: 23
Joined: Tue Jan 19, 2016 3:26 pm

cBB Editor error, breaks the ACP

Postby Swamp_Monkey » Tue Apr 23, 2019 11:13 am • via Web
It breaks the ACP, I get the following error:

Code: Select all
Fatal error: Uncaught Error: Class 'canidevcoretemplate' not found in /path/to/ext/canidev/editor/libraries/editor.php:76 Stack trace: #0 [internal function]: canideveditorlibrarieseditor->__construct(Object(phpbbauthauth), Object(canideveditorlibrariesbbcodesparser), Object(phpbbconfigdb), Object(phpbbconfigdb_text), Object(SymfonyComponentDependencyInjectionContainerBuilder), Object(phpbbdbdriverfactory), Object(phpbbeventdispatcher), Object(phpbblanguagelanguage), Object(phpbbpath_helper), Object(phpbbrequestrequest), Object(phpbbuser), 'php') #1 /path/to/vendor/symfony/dependency-injection/ContainerBuilder.php(925): ReflectionClass->newInstanceArgs(Array) #2 /path/to/vendor/symfony/dependency-injection/ContainerBuilder.php(467): SymfonyComponentDependencyInjectionContainerBuilder->createService(Object(SymfonyComponentDependencyInjectionDefinition), Object(SplObjectStor in /path/to/ext/canidev/editor/libraries/editor.php on line 76


I can no longer access the ACP, but the forum actually works (the editor does not).

(running phpBB 3.2.5, error occurs in both prosilver and FLATBOOTS, MySQL(i) 5.6.41-84.1, PHP 7.1.24)
User avatar

IvanPF
Site Admin
 
Posts: 1641
Joined: Fri Jun 17, 2011 12:15 am
Location: España (Spain)

Re: cBB Editor error, breaks the ACP

Postby IvanPF » Tue Apr 23, 2019 11:50 am • via Web
Hi,

Have you uploaded all the contents of the package, including the "core" folder?


Swamp_Monkey
 
Posts: 23
Joined: Tue Jan 19, 2016 3:26 pm

Re: cBB Editor error, breaks the ACP

Postby Swamp_Monkey » Tue Apr 23, 2019 1:18 pm • via Web
Well I feel really foolish now. That was it. Thanks!

I have another small issue. Under FLATBOOTS, the original posting buttons still show up. This doesn't happen under prosilver, so I assume it's a FLATBOOTS issue (yes, I installed the appropriate FLATBOOTS style components for both the core and the editor).
User avatar

IvanPF
Site Admin
 
Posts: 1641
Joined: Fri Jun 17, 2011 12:15 am
Location: España (Spain)

Re: cBB Editor error, breaks the ACP

Postby IvanPF » Tue Apr 23, 2019 1:27 pm • via Web
It is possible that some extension will interfere because it should not appear if you have installed the style adaptation.
Can you give me access to the publication page of your forum with a test user or similar so you can see it?


Swamp_Monkey
 
Posts: 23
Joined: Tue Jan 19, 2016 3:26 pm

Re: cBB Editor error, breaks the ACP

Postby Swamp_Monkey » Tue Apr 23, 2019 1:56 pm • via Web
IvanPF wrote:It is possible that some extension will interfere because it should not appear if you have installed the style adaptation.
Can you give me access to the publication page of your forum with a test user or similar so you can see it?


Yes, I'm trying to figure out which extensions will work with it and which won't.

There appears to be an issue with the phpBB Media Embed Plugin extension. If you insert one of the supported media types, the post will appear but nothing afterwards (i.e., no buttons, no way to reply or post after that). Completely breaks the page on which it's posted.

*Private content*


Swamp_Monkey
 
Posts: 23
Joined: Tue Jan 19, 2016 3:26 pm

Re: cBB Editor error, breaks the ACP

Postby Swamp_Monkey » Tue Apr 23, 2019 2:33 pm • via Web
Seems like any extension that adds a custom BBCode breaks the editor as well - BB@mention for FLATBOOTS screws it all up, but not if I remove the BBCodes it adds.

Manually-added custom BBCodes are fine, however.
User avatar

IvanPF
Site Admin
 
Posts: 1641
Joined: Fri Jun 17, 2011 12:15 am
Location: España (Spain)

Re: cBB Editor error, breaks the ACP

Postby IvanPF » Tue Apr 23, 2019 3:06 pm • via Web
There appears to be an issue with the phpBB Media Embed Plugin extension. If you insert one of the supported media types, the post will appear but nothing afterwards (i.e., no buttons, no way to reply or post after that). Completely breaks the page on which it's posted.

This extension has been tested and should work with the publisher (at least in prosilver).
What bbcode gives you the error? Can you give me an example of text that proves the fault?

Code: Select all
Seems like any extension that adds a custom BBCode breaks the editor as well - BB@mention for FLATBOOTS screws it all up, but not if I remove the BBCodes it adds.

I do not know that extension but, if two extensions use a similar called bbcode or some similar feature, they will give you an error.
For example, for flatboots I think there is an extension called "bbcode order" that gives problems because it uses variables that the editor also uses.

I have reviewed the button problem.
It seems that the template of your style has some change with respect to the original FLATBOOTS.
I have edited a file from the editor, upload it to the folder /ext/canidev/editor/styles/FLATBOOTS/theme/ and then clean the cache from the ACP. That should solve the problem.
Attachments
editor.css
(13.47 KB) 18 times


Swamp_Monkey
 
Posts: 23
Joined: Tue Jan 19, 2016 3:26 pm

Re: cBB Editor error, breaks the ACP

Postby Swamp_Monkey » Tue Apr 23, 2019 3:37 pm • via Web
You're the best! I didn't realize that my template was messed up, I probably messed with it at some point trying to get something to work, but I'm usually good at fixing it! Anyway, thanks for the quick response.

Yes, I had disabled bbcodeorder+ because I figured it would cause problems (also smart snappy reply).

I'll keep looking at the media embed plugin and see if I can recreate the error on a clean install.

Thanks for creating this extension, by the way, this is something I've been wanting for a LONG time.


Swamp_Monkey
 
Posts: 23
Joined: Tue Jan 19, 2016 3:26 pm

Re: cBB Editor error, breaks the ACP

Postby Swamp_Monkey » Tue Apr 23, 2019 8:49 pm • via Web
This is what happens when you try to embed media with the phpBB Media Embed plugin:

https://www.alligatorunderground.com/ph ... f=21&t=284

See how there's nothing after the post? It should be like a normal thread.

HOWEVER, those sites supported by cBB Editor (Twitter, YouTube, Facebook, etc.) all work normally.
User avatar

IvanPF
Site Admin
 
Posts: 1641
Joined: Fri Jun 17, 2011 12:15 am
Location: España (Spain)

Re: cBB Editor error, breaks the ACP

Postby IvanPF » Tue Apr 23, 2019 9:02 pm • via Web
Thanks for report. I will try to find the problem
Next

Who is online

Users browsing this forum: Bing [Bot] and 2 guests