Doubt about Core Folder


User avatar

Leinad4Mind
 
Posts: 110
Joined: Thu Oct 15, 2015 10:10 pm

Doubt about Core Folder

Postby Leinad4Mind » Sun Mar 17, 2019 2:35 pm • via Web
I saw there is some differences between the "core" folder files of Chat 1.2.0 and QuickQuote 1.0.1.

Since the chat was released after, should I use that one instead?
User avatar

IvanPF
Site Admin
 
Posts: 1640
Joined: Fri Jun 17, 2011 12:15 am
Location: España (Spain)

Re: Doubt about Core Folder

Postby IvanPF » Sun Mar 17, 2019 8:14 pm • via Web
The last extension that you download will always have the updated "core". For that reason, you should always overwrite the files.
The date of publication of the extension does not matter since the files are updated at the time of download.

It is not common to use common libraries between extensions but, in this way, I reduce the functions and size of the extensions and avoid incompatibilities between them.
User avatar

Leinad4Mind
 
Posts: 110
Joined: Thu Oct 15, 2015 10:10 pm

Re: Doubt about Core Folder

Postby Leinad4Mind » Sun Mar 17, 2019 9:12 pm • via Web
It could even be an external ext, that way we would know that we've the last one. But its fine as it is anyway, Thanks for the info!
User avatar

IvanPF
Site Admin
 
Posts: 1640
Joined: Fri Jun 17, 2011 12:15 am
Location: España (Spain)

Re: Doubt about Core Folder

Postby IvanPF » Mon Mar 18, 2019 11:15 am • via Web
Yes, it is an option. But in that way every time you update an extension you should be aware and also update the core, because it is possible that the new version of the extension needs it updated. This implies that, instead of updating an extension, the user has to update two and, if it does not, it is possible that an error will appear. The way it is configured, I make sure it is always updated, that it will not give errors and I take away from the user the need to install an additional extension.
User avatar

Leinad4Mind
 
Posts: 110
Joined: Thu Oct 15, 2015 10:10 pm

Re: Doubt about Core Folder

Postby Leinad4Mind » Mon Mar 18, 2019 12:31 pm • via Web
I understand. Its just that the installation order would matter. I mean, if you install first cbb chat (it was the last one to be released) and then install cbb Quickquote (with an older core I assume), then maybe problem could occur.
And many people would not check which core is more recent. They'll just send the files and overwrite it all. Thats was only my concern. Basically it seems that for each new extension you release that uses the core, you'll need to update all the others packages exts with the last core.
User avatar

IvanPF
Site Admin
 
Posts: 1640
Joined: Fri Jun 17, 2011 12:15 am
Location: España (Spain)

Re: Doubt about Core Folder

Postby IvanPF » Mon Mar 18, 2019 3:02 pm • via Web
Yes, but that will only happen if you install an old ext, whose zip you have saved. If you download the extension from the web it does not matter the version, the core will always be updated because it is not included in the packages, it is added at the time of download.
User avatar

Leinad4Mind
 
Posts: 110
Joined: Thu Oct 15, 2015 10:10 pm

Re: Doubt about Core Folder

Postby Leinad4Mind » Mon Mar 18, 2019 4:19 pm • via Android
Ohhhh I see! Awesome!

Who is online

Users browsing this forum: No registered users and 1 guest