Quickquote - multiple quotes not working




nou nou
 
Posts: 27
Joined: Thu Nov 16, 2017 4:31 am

Quickquote - multiple quotes not working

Postby nou nou » Thu Mar 08, 2018 9:17 pm • via Web
Hello,


I've instaled Quickquote and the reply command works well. I can see the enormous benefit of the extension but there are a couple of issues that prevent me from using it on a live board.

First of all, "reply" replaces any content that is already in the Quick Reply box. It would be better if it could append it, very often users want to reply to several small questions or comments from previous posts. Quickquote would be an amazing tool for that. For me it would basically replace the need for saving several quotes in a separate function.

Speaking of the saving quotes - that doesn't work for me. I can save the quotes, the button appears at the bottom and I can see the quotes in there. However I cannot get them pasted into a post. This error message appears in the console:

Code: Select all
Error: Method undefined does not exist on jQuery.caret
jquery.min.js:2:1819
error
https://mywebsite/assets/javascript/jquery.min.js:2:1819
a.fn.caret
https://mywebsite/ext/paul999/mention/styles/all/template/js/utils/jquery.caret.min.js:2:6085
dialogTrigger
https://mywebsite/ext/canidev/quickquote/styles/all/template/quickquote.min.js:9:4946
initDialog/<
https://mywebsite/ext/canidev/quickquote/styles/all/template/quickquote.min.js:9:3239
dispatch
https://mywebsite/assets/javascript/jquery.min.js:3:8014
add/r.handle
https://mywebsite/assets/javascript/jquery.min.js:3:4750


It turns out there is a conflict with the following phpBB extension: https://www.phpbb.com/customise/db/exte ... _mentions/

Hope this all makes sense to you... :)
Thanks!
User avatar

IvanPF
Site Admin
 
Posts: 1434
Joined: Fri Jun 17, 2011 12:15 am
Location: España (Spain)

Re: Quickquote - multiple quotes not working

Postby IvanPF » Fri Mar 09, 2018 4:25 pm • via Web
Hi,

As you mentioned, the "Simple Mentions" extension causes a problem in cBB QuickQuote.
I have gone back to upload the package with a change that should solve the problem.
Please download the package again, upload the files to your hosting and clear the cache from the ACP. That would have to correct the problem


nou nou
 
Posts: 27
Joined: Thu Nov 16, 2017 4:31 am

Re: Quickquote - multiple quotes not working

Postby nou nou » Tue Mar 13, 2018 3:59 am • via Web
Works beautifully now - thank you! :)

I would still like to request (if at all possible) the option to append messages with the reply button, rather than replace them.

As the cherry on the cake, it would be amazing if that could be made into a UCP option as well, so users can choose how they would like to see it work. The option currently set in the ACP (hovering button / added button in editor) would be a great UCP option as well.

Thanks!
User avatar

IvanPF
Site Admin
 
Posts: 1434
Joined: Fri Jun 17, 2011 12:15 am
Location: España (Spain)

Re: Quickquote - multiple quotes not working

Postby IvanPF » Tue Mar 13, 2018 1:27 pm • via Web
Thanks for the suggestions.
I will keep them in mind for the next version

Who is online

Users browsing this forum: No registered users and 1 guest

cron