- Estás aquí:
- Inicio › Foro › Application Support
cBB Blockgets
Debido a falta de tiempo libre, tanto el soporte en este foro como el desarrollo de extensiones es limitado actualmente.
Todos los bugs son tenidos en cuenta y guardados para su correción aunque no haya respuesta en los posts.
Se retomará la actividad normal tan pronto sea posible.
Todos los bugs son tenidos en cuenta y guardados para su correción aunque no haya respuesta en los posts.
Se retomará la actividad normal tan pronto sea posible.
10 mensajes
• Página 1 de 1
-

- kris
- Mensajes: 19
- Registrado: Lun Oct 28, 2024 6:53 am
Mar Oct 29, 2024 8:45 am • a través de Web
- Código: Seleccionar todo
SQL ERROR [ mysqli ]
Table 'dbah3qvfgg1qov.soft_blockgets_blocks' doesn't exist [1146]
SQL
INSERT INTO soft_blockgets_blocks (block_title, block_content, block_alias, block_icon, block_order, block_position, block_page, block_groups, bbcode_bitfield, bbcode_uid) VALUES ('Menu', 'a:1:{s:4:\"list\";a:8:{i:0;a:7:{s:5:\"title\";s:4:\"Main\";s:11:\"description\";s:0:\"\";s:3:\"url\";s:0:\"\";s:5:\"image\";s:0:\"\";s:6:\"window\";i:0;s:6:\"groups\";s:3:\"all\";s:4:\"type\";i:0;}i:1;a:7:{s:5:\"title\";s:6:\"Portal\";s:11:\"description\";s:0:\"\";s:3:\"url\";s:6:\"portal\";s:5:\"image\";s:7:\"fa-home\";s:6:\"window\";i:0;s:6:\"groups\";s:3:\"all\";s:4:\"type\";i:1;}i:2;a:7:{s:5:\"title\";s:10:\"Index page\";s:11:\"description\";s:0:\"\";s:3:\"url\";s:9:\"index.php\";s:5:\"image\";s:13:\"fa-comments-o\";s:6:\"window\";i:0;s:6:\"groups\";s:3:\"all\";s:4:\"type\";i:1;}i:3;a:7:{s:5:\"title\";s:3:\"FAQ\";s:11:\"description\";s:0:\"\";s:3:\"url\";s:7:\"faq.php\";s:5:\"image\";s:18:\"fa-question-circle\";s:6:\"window\";i:0;s:6:\"groups\";s:3:\"all\";s:4:\"type\";i:1;}i:4;a:7:{s:5:\"title\";s:6:\"Search\";s:11:\"description\";s:0:\"\";s:3:\"url\";s:10:\"search.php\";s:5:\"image\";s:9:\"fa-search\";s:6:\"window\";i:0;s:6:\"groups\";s:7:\"2,4,5,7\";s:4:\"type\";i:1;}i:5;a:7:{s:5:\"title\";s:14:\"Administration\";s:11:\"description\";s:0:\"\";s:3:\"url\";s:0:\"\";s:5:\"image\";s:0:\"\";s:6:\"window\";i:0;s:6:\"groups\";s:3:\"4,5\";s:4:\"type\";i:0;}i:6;a:7:{s:5:\"title\";s:16:\"Moderation Panel\";s:11:\"description\";s:0:\"\";s:3:\"url\";s:7:\"mcp.php\";s:5:\"image\";s:8:\"fa-legal\";s:6:\"window\";i:0;s:6:\"groups\";s:3:\"4,5\";s:4:\"type\";i:1;}i:7;a:7:{s:5:\"title\";s:20:\"Administration Panel\";s:11:\"description\";s:0:\"\";s:3:\"url\";s:13:\"adm/index.php\";s:5:\"image\";s:7:\"fa-cogs\";s:6:\"window\";i:0;s:6:\"groups\";s:1:\"5\";s:4:\"type\";i:1;}}}', 'menu_block', 'fa-home', 1, 1, 1, 'all', '', ''), ('Clock', 'tri_amber.swf', 'clock_block', 'fa-clock-o', 2, 1, 1, 'all', '', ''), ('Link Us', 'a:1:{s:10:\"banner_url\";s:28:\"./banners/canidev-banner.png\";}', 'link_us_block', 'fa-link', 3, 1, 1, 'all', '', ''), ('Welcome', 'a:2:{s:10:\"guest_text\";s:398:\"[html]<div style="text-align:center; font-size:1.2em;"><a href="https://www.canidev.com"><span class="blg-image logo-img"></span></a><br /><strong><i>Forum equipped with cBB Blockgets</i><br /><br />Welcome to our forum!<br />Register to access all the content!.</strong></div>[/html]\";s:11:\"member_text\";s:367:\"[html]<div style="text-align:center; font-size:1.2em;"><a href="https://www.canidev.com"><span class="blg-image logo-img"></span></a><br /><strong><i>Forum equipped with cBB Blockgets</i><br /><br />Welcome back to our forum {S_USERNAME}</strong></div>[/html]\";}', 'welcome_block', 'fa-flag', 1, 2, 1, 'all', '', ''), ('Dock menu', 'a:2:{s:10:\"item_width\";i:40;s:4:\"list\";a:4:{i:0;a:5:{s:5:\"title\";s:6:\"Portal\";s:3:\"url\";s:6:\"portal\";s:5:\"image\";s:16:\"./icons/home.png\";s:6:\"window\";i:0;s:6:\"groups\";s:3:\"all\";}i:1;a:5:{s:5:\"title\";s:10:\"Index page\";s:3:\"url\";s:9:\"index.php\";s:5:\"image\";s:21:\"./icons/documents.png\";s:6:\"window\";i:0;s:6:\"groups\";s:3:\"all\";}i:2;a:5:{s:5:\"title\";s:3:\"FAQ\";s:3:\"url\";s:7:\"faq.php\";s:5:\"image\";s:17:\"./icons/float.png\";s:6:\"window\";i:0;s:6:\"groups\";s:3:\"all\";}i:3;a:5:{s:5:\"title\";s:6:\"Search\";s:3:\"url\";s:10:\"search.php\";s:5:\"image\";s:15:\"./icons/box.png\";s:6:\"window\";i:0;s:6:\"groups\";s:3:\"all\";}}}', 'dockmenu_block', 'fa-globe', 2, 2, 1, 'all', '', ''), ('Recent Topics', 'a:3:{s:11:\"topic_limit\";i:5;s:11:\"title_limit\";i:50;s:6:\"forums\";a:0:{}}', 'recent_topics_block', 'fa-comment', 3, 2, 1, 'all', '', ''), ('Who\'s online', 'a:2:{s:8:\"advanced\";i:1;s:9:\"usernames\";i:1;}', 'whos_online_block', 'fa-user', 4, 2, 1, 'all', '', ''), ('Login', 'a:2:{s:10:\"full_login\";i:1;s:13:\"show_register\";i:1;}', 'login_block', 'fa-user', 1, 3, 1, 'all', '', ''), ('Statistics', 'a:2:{s:12:\"stats_inline\";i:0;s:10:\"user_stats\";i:1;}', 'stats_block', 'fa-bar-chart', 2, 3, 1, 'all', '', ''), ('FORUM', '', 'forum_content', '', 1, 2, 2, 'all', '', ''), ('Most Posters', 'a:2:{s:12:\"poster_limit\";i:5;s:12:\"poster_range\";s:4:\"none\";}', 'most_poster_block', 'fa-edit', 1, 3, 2, 'all', '', '')
BACKTRACE
FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()
FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 1028
CALL: trigger_error()
FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 202
CALL: phpbb\db\driver\driver->sql_error()
FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 690
CALL: phpbb\db\driver\mysqli->sql_query()
FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 401
CALL: phpbb\db\driver\driver->sql_multi_insert()
FILE: [ROOT]/ext/canidev/blockgets/migrations/v200.php
LINE: 443
CALL: phpbb\db\driver\factory->sql_multi_insert()
FILE: (not given by php)
LINE: (not given by php)
CALL: canidev\blockgets\migrations\v200->add_table_data()
FILE: [ROOT]/phpbb/db/migrator.php
LINE: 715
CALL: call_user_func_array()
FILE: [ROOT]/phpbb/db/migrator.php
LINE: 662
CALL: phpbb\db\migrator->run_step()
FILE: [ROOT]/phpbb/db/migrator.php
LINE: 437
CALL: phpbb\db\migrator->process_data_step()
FILE: [ROOT]/phpbb/db/migrator.php
LINE: 288
CALL: phpbb\db\migrator->try_apply()
FILE: [ROOT]/phpbb/db/migrator.php
LINE: 241
CALL: phpbb\db\migrator->update_do()
FILE: [ROOT]/phpbb/extension/base.php
LINE: 78
CALL: phpbb\db\migrator->update()
FILE: [ROOT]/ext/canidev/blockgets/ext.php
LINE: 72
CALL: phpbb\extension\base->enable_step()
FILE: [ROOT]/phpbb/extension/manager.php
LINE: 231
CALL: canidev\blockgets\ext->enable_step()
FILE: [ROOT]/includes/acp/acp_extensions.php
LINE: 209
CALL: phpbb\extension\manager->enable_step()
FILE: [ROOT]/includes/functions_module.php
LINE: 676
CALL: acp_extensions->main()
FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()
-

- IvanPF
- Administrador
- Mensajes: 2265
- Registrado: Vie Jun 17, 2011 12:15 am
- Ubicación: España (Spain)
Mar Oct 29, 2024 9:18 am • a través de Web
It appears that the phpBB installer has failed and has not inserted all tables into the database.
If the extension is listed in the ACP, please uninstall it and try again.
If the extension is listed in the ACP, please uninstall it and try again.
-

- kris
- Mensajes: 19
- Registrado: Lun Oct 28, 2024 6:53 am
Mar Oct 29, 2024 9:29 am • a través de Web
Hi,I reinstalled it and it still gives me an error
-

- IvanPF
- Administrador
- Mensajes: 2265
- Registrado: Vie Jun 17, 2011 12:15 am
- Ubicación: España (Spain)
Mar Oct 29, 2024 9:39 am • a través de Web
The installation process can fail for many reasons beyond its control. If you have access to the error log, see if anything appears at the time of installation.
Have you completely uninstalled it, disabling and erasing data?
Do you have access to the database to see which tables are created? If so, check if the blockgets tables are there.
Have you completely uninstalled it, disabling and erasing data?
Do you have access to the database to see which tables are created? If so, check if the blockgets tables are there.
-

- kris
- Mensajes: 19
- Registrado: Lun Oct 28, 2024 6:53 am
Mar Oct 29, 2024 10:03 am • a través de Web
Yes, after I deleted the table containing blockgets from MYSQL again, and reinstalled it, it still reported an error
-

- IvanPF
- Administrador
- Mensajes: 2265
- Registrado: Vie Jun 17, 2011 12:15 am
- Ubicación: España (Spain)
Mié Oct 30, 2024 7:58 pm • a través de Web
You may be having problems with leftovers from the incomplete installation. I can tell you the steps to clean it up directly in the database.
I also attach the queries to do it more quickly.
First, backup the database and uninstall the extension in ACP
Some of the records may not exist, this is to make sure everything is clean.
In table soft_config remove all entries with "config_name" starts with "blg_"
In table soft_ext remove entry with "ext_name" equal to "canidev/blockgets"
In table soft_migrations remove all entries with "migration_name" starts with "\canidev\blockgets\"
This is the most important thing, the records in this table directly influence the installation.
Remove all extensions tables
soft_blockgets_blocks, soft_blockgets_data, soft_blockgets_pages
Clear the cache in ACP and reinstall.
I also attach the queries to do it more quickly.
First, backup the database and uninstall the extension in ACP
Some of the records may not exist, this is to make sure everything is clean.
In table soft_config remove all entries with "config_name" starts with "blg_"
- Código: Seleccionar todo
DELETE FROM soft_config WHERE config_name LIKE 'blg_%';
In table soft_ext remove entry with "ext_name" equal to "canidev/blockgets"
- Código: Seleccionar todo
DELETE FROM soft_ext WHERE ext_name = 'canidev/blockgets';
In table soft_migrations remove all entries with "migration_name" starts with "\canidev\blockgets\"
This is the most important thing, the records in this table directly influence the installation.
- Código: Seleccionar todo
DELETE FROM soft_migrations WHERE migration_name LIKE '\\\\canidev\\\\blockgets%'
Remove all extensions tables
soft_blockgets_blocks, soft_blockgets_data, soft_blockgets_pages
- Código: Seleccionar todo
DROP TABLE `soft_blockgets_blocks`;
DROP TABLE `soft_blockgets_data`;
DROP TABLE `soft_blockgets_pages`;
Clear the cache in ACP and reinstall.
-

- kris
- Mensajes: 19
- Registrado: Lun Oct 28, 2024 6:53 am
Vie Nov 01, 2024 2:18 am • a través de Web
Hi,
Remove all extensions tables
The error returned when I execute the SQL
#1051 - Unknown table 'dbah3qvfgg1qov.soft_blockgets_blocks'
Remove all extensions tables
The error returned when I execute the SQL
#1051 - Unknown table 'dbah3qvfgg1qov.soft_blockgets_blocks'
-

- kris
- Mensajes: 19
- Registrado: Lun Oct 28, 2024 6:53 am
Vie Nov 01, 2024 2:21 am • a través de Web
ACP:
Something went wrong during the request and an exception was thrown. The changes made before the error occurred were reversed to the best of our abilities, but you should check the board for errors.
A module already exists: ACP_BLOCKGETS
Something went wrong during the request and an exception was thrown. The changes made before the error occurred were reversed to the best of our abilities, but you should check the board for errors.
A module already exists: ACP_BLOCKGETS
-

- kris
- Mensajes: 19
- Registrado: Lun Oct 28, 2024 6:53 am
Vie Nov 01, 2024 2:40 am • a través de Web
Even if I delete the module inside the system and activate it again, I still get the same problem!
-

- kris
- Mensajes: 19
- Registrado: Lun Oct 28, 2024 6:53 am
Vie Nov 01, 2024 5:48 am • a través de Web
I solved it.
10 mensajes
• Página 1 de 1
¿Quién está conectado?
Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 0 invitados
- Contenido
- Descargas
- En desarrollo
- Comunidad y Soporte
- Rss
- Enlaces de Interés
- phpBB Oficial
- phpBB Oficial (Español)
- Raul Arroyo Monzo
- PasionReef
- Sobre CaniDev
- Condiciones de uso
- Política de Privacidad
- Sobre nosotros
- Contacto
- © 2011-2026 CaniDev